Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...

microsoft.public.de.windows.vista.netzwerk






Speedup My PC
Reply
  #1 (permalink)  
Old 06-15-2008
Kerem Gümrükcü
 

Posts: n/a
Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Hallo,

das ist kein reine 2000/XP/Vista Frage, aber ich traue mich mal
dennoch diese zu stellen,...*g*

Ich habe einen Windows XP Pro Computer, der mit einem
WLAN Adapter mit einem WLAN Router verbunden ist. Auf
dem Computer sind einige Netzwerkschnitstellen, darunter einige
Software Adapter, die ich zum Netz-Simmulieren und für meine Programme
benutze. Im WLAN Netz habe ich noch einen Vista UE und einen
Windows 2000 Pro Rechner. Ich habe ein Programm geschrieben,
das im Netzwerk die Rechnernamen in IP Addressen auflöst. Genau
genommen, ist es ein kleiner Teil des Programmes. Nun wird aber
der Hostname des XP Computers immer in die 192.169.1.9
aufgelöst, wobei das die IP eines Pseudoadapters ist, der keine
physische Verbindung mit dem (W)LAN hat, sondern nur als
Softwaretreiber auf dem Rechner liegt. Die einzige Adresse, die der
Rechner "ansprechbar" hat, also über das WLAN ist die 192.169.1.3.
Warum aber bekomme ich bei einer Namensuaflösung immer diese 9
anstelle der 3. Irgendwas stimmt mit den Netzwerkeinstellungen meines
XP Pro anscheinend nicht, aber nur was. Alle rechner geben die richtige
"ansprechbare" Adresse zurück, nur der XP Pro nicht. Was kann das sein?

Hat jemand eine Idee,...?

Danke schon mal,...

Grüße

Kerem

--
--
-----------------------
Beste Grüsse / Best regards / Votre bien devoue
Kerem Gümrükcü
Microsoft Live Space: http://kerem-g.spaces.live.com/
Latest Open-Source Projects: http://entwicklung.junetz.de
-----------------------
"This reply is provided as is, without warranty express or implied."


Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 06-15-2008
Ralf Breuer
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Kerem Gümrükcü <kareem114@hotmail.com> schrieb:

Hallo Kerem,

> Ich habe einen Windows XP Pro Computer, der mit einem
> WLAN Adapter mit einem WLAN Router verbunden ist. Auf
> dem Computer sind einige Netzwerkschnitstellen, darunter einige
> Software Adapter, die ich zum Netz-Simmulieren und für meine Programme
> benutze. Im WLAN Netz habe ich noch einen Vista UE und einen
> Windows 2000 Pro Rechner. Ich habe ein Programm geschrieben,
> das im Netzwerk die Rechnernamen in IP Addressen auflöst. Genau
> genommen, ist es ein kleiner Teil des Programmes. Nun wird aber
> der Hostname des XP Computers immer in die 192.169.1.9
> aufgelöst, wobei das die IP eines Pseudoadapters ist, der keine
> physische Verbindung mit dem (W)LAN hat, sondern nur als
> Softwaretreiber auf dem Rechner liegt. Die einzige Adresse, die der
> Rechner "ansprechbar" hat, also über das WLAN ist die 192.169.1.3.
> Warum aber bekomme ich bei einer Namensuaflösung immer diese 9
> anstelle der 3.


Die verschiedenen Adapter sind im gleichen Subnetz, was "nicht zulässig"
ist, zumindest aber für Verwirrung sorgt.
Die sauberste Lösung ist, die Adapter mit IPs aus unterschiedlichen
Subnetzen zu versorgen.
Wenn Du mit der Brechstange Deine Konstellation behalten willst, schau in
Systemsteueung, Netzwerkverbindungen, im Kopf: Erweitert, erweiterte
Einstellungen, Netzwerkkarten und Bindungen. Die (W)Lan-Verbindung nach oben
schieben.

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Reply With Quote
  #3 (permalink)  
Old 06-15-2008
Kerem Gümrükcü
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Hallo Ralf,

>Wenn Du mit der Brechstange Deine Konstellation behalten willst, schau in
>Systemsteueung, Netzwerkverbindungen, im Kopf: Erweitert, erweiterte
>Einstellungen, Netzwerkkarten und Bindungen. Die (W)Lan-Verbindung nach
>oben schieben.


Zucker!, Das wars und ich habe wieder an die kompliziertesten Dinge gedacht,
aber
nicht daran,...

Ich bin Programmierer und brauche diese Sachen, da ich momentan viel an
Netzwer-
programmen, Firewalls und Kernel-Treibern schreibe. Dafür benötige ich
virtuelle
Netzwerke, an denen ich meine Pakete "durchschieben" kann, daher auch diese
vielen Adapter und ein großes Netz. Begleitet werde ich vom Netzwerkmonitor
und dem "Kabelhai" (Wireshark),...

Vielen Dank, das war die Lösung,...

Schönen Sonntag,..

Grüße

Kerem


--
-----------------------
Beste Grüsse / Best regards / Votre bien devoue
Kerem Gümrükcü
Microsoft Live Space: http://kerem-g.spaces.live.com/
Latest Open-Source Projects: http://entwicklung.junetz.de
-----------------------
"This reply is provided as is, without warranty express or implied."


Reply With Quote
  #4 (permalink)  
Old 06-15-2008
Ralf Breuer
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Kerem Gümrükcü <kareem114@hotmail.com> schrieb:

> Vielen Dank, das war die Lösung,...


bitte :-)

> Schönen Sonntag,..


danke dito :-)

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Reply With Quote
  #5 (permalink)  
Old 06-16-2008
Kerem Gümrükcü
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Hallo Ralf,

nun, es erweckte den Anschein, als wenn es funktioniert hat,
aber obwohl die aktive Karte bei den Bindungen und der
Anbieterreinfolge ganz oben ist und das gleiche Gültigkeit
für die Protokollbindungen (IP4 und IP6) hat, bekomme
ich bei einer Auflösung "wieder" diese 9 statt die 3. Das
ist irgendwie nix. Hier eine Ausgabe von "ipconfig / all";



Windows-IP-Konfiguration



Hostname. . . . . . . . . . . . . : tiberius01

Primäres DNS-Suffix . . . . . . . :

Knotentyp . . . . . . . . . . . . : Broadcast

IP-Routing aktiviert. . . . . . . : Ja

WINS-Proxy aktiviert. . . . . . . : Ja



Ethernetadapter VMware Network Adapter VMnet8:



Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : VMware Virtual Ethernet Adapter
for VMnet8

Physikalische Adresse . . . . . . : 00-50-56-C0-00-08

DHCP aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.183.1

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

IP-Adresse. . . . . . . . . . . . : fe80::250:56ff:fec0:8%4

Standardgateway . . . . . . . . . :

DNS-Server. . . . . . . . . . . . : fec0:0:0:ffff::1%7

fec0:0:0:ffff::2%7

fec0:0:0:ffff::3%7



Ethernetadapter VMware Network Adapter VMnet1:



Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : VMware Virtual Ethernet Adapter
for VMnet1

Physikalische Adresse . . . . . . : 00-50-56-C0-00-01

DHCP aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.44.1

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

IP-Adresse. . . . . . . . . . . . : fe80::250:56ff:fec0:1%5

Standardgateway . . . . . . . . . :

DNS-Server. . . . . . . . . . . . : fec0:0:0:ffff::1%6

fec0:0:0:ffff::2%6

fec0:0:0:ffff::3%6



Ethernetadapter Realtek RTL8139-Familie-PCI-Fast Ethernet-NIC:



Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung

Beschreibung. . . . . . . . . . . : Realtek RTL8139-Familie-PCI-Fast
Ethernet-NIC

Physikalische Adresse . . . . . . : 03-02-4D-AD-AF-1E



Ethernetadapter TAP-Win32 Adapter V8 (coLinux) #2:



Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung

Beschreibung. . . . . . . . . . . : TAP-Win32 Adapter V8 (coLinux)
#2

Physikalische Adresse . . . . . . : 00-FF-88-E4-FC-D9



Ethernetadapter TAP-Win32 Adapter V8 (coLinux):



Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung

Beschreibung. . . . . . . . . . . : TAP-Win32 Adapter V8 (coLinux)

Physikalische Adresse . . . . . . : 00-FF-CB-21-E9-45



Ethernetadapter TAP-Win32 Adapter V8:



Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : TAP-Win32 Adapter V8

Physikalische Adresse . . . . . . : 00-FF-67-F3-D8-C6

DHCP aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.1.9

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

IP-Adresse. . . . . . . . . . . . : fe80::2ff:67ff:fef3:d8c6%9

Standardgateway . . . . . . . . . : 192.168.1.1

DNS-Server. . . . . . . . . . . . : 192.168.1.1

fec0:0:0:ffff::1%4

fec0:0:0:ffff::2%4

fec0:0:0:ffff::3%4



Ethernetadapter Sitecom Wireless Network USB Adapter 54G WL-113:



Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : Sitecom Wireless Network USB
Adapter 54G WL-113 #2

Physikalische Adresse . . . . . . : 02-0C-21-DF-2F-A2

DHCP aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.1.3

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

IP-Adresse. . . . . . . . . . . . : fe80::20c:f6ff:fe16:b0ff%11

Standardgateway . . . . . . . . . : 192.168.1.1

DNS-Server. . . . . . . . . . . . : 192.168.1.1

fec0:0:0:ffff::1%1

fec0:0:0:ffff::2%1

fec0:0:0:ffff::3%1



Tunneladapter Teredo Tunneling Pseudo-Interface:



Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : Teredo Tunneling
Pseudo-Interface

Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-00

DHCP aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : fe80::ffff:ffff:fffd%10

Standardgateway . . . . . . . . . : ::

NetBIOS über TCP/IP . . . . . . . : Deaktiviert


Ich verstehe nicht, warum das so ist, vor allem nicht, warum der
falsche Name mit dem Hostnamen aufgelöst wird. Welche
Optionen/Möglichkeiten habe ich noch, um der Sache auf
den Grund zu gehen,...?

Danke schon mal,...


Grüße

Kerem



--
-----------------------
Beste Grüsse / Best regards / Votre bien devoue
Kerem Gümrükcü
Microsoft Live Space: http://kerem-g.spaces.live.com/
Latest Open-Source Projects: http://entwicklung.junetz.de
-----------------------
"This reply is provided as is, without warranty express or implied."


Reply With Quote
  #6 (permalink)  
Old 06-16-2008
Ralf Breuer
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Kerem Gümrükcü <kareem114@hotmail.com> schrieb:

> Windows-IP-Konfiguration
> Hostname. . . . . . . . . . . . . : tiberius01
> Knotentyp . . . . . . . . . . . . : Broadcast
> IP-Routing aktiviert. . . . . . . : Ja
> WINS-Proxy aktiviert. . . . . . . : Ja
> Ethernetadapter VMware Network Adapter VMnet8:
> IP-Adresse. . . . . . . . . . . . : 192.168.183.1
> IP-Adresse. . . . . . . . . . . . : fe80::250:56ff:fec0:8%4
> Ethernetadapter VMware Network Adapter VMnet1:
> IP-Adresse. . . . . . . . . . . . : 192.168.44.1
> Ethernetadapter Realtek RTL8139-Familie-PCI-Fast Ethernet-NIC:
> Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung
> Ethernetadapter TAP-Win32 Adapter V8 (coLinux) #2:
> Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung
> Ethernetadapter TAP-Win32 Adapter V8 (coLinux):
> Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung
> Ethernetadapter TAP-Win32 Adapter V8:
> IP-Adresse. . . . . . . . . . . . : 192.168.1.9
> Subnetzmaske. . . . . . . . . . . : 255.255.255.0
> IP-Adresse. . . . . . . . . . . . : fe80::2ff:67ff:fef3:d8c6%9
> Standardgateway . . . . . . . . . : 192.168.1.1
> DNS-Server. . . . . . . . . . . . : 192.168.1.1
> Ethernetadapter Sitecom Wireless Network USB Adapter 54G WL-113:
> IP-Adresse. . . . . . . . . . . . : 192.168.1.3
> Subnetzmaske. . . . . . . . . . . : 255.255.255.0
> IP-Adresse. . . . . . . . . . . . : fe80::20c:f6ff:fe16:b0ff%11
> Standardgateway . . . . . . . . . : 192.168.1.1
> DNS-Server. . . . . . . . . . . . : 192.168.1.1
> Tunneladapter Teredo Tunneling Pseudo-Interface:
>
> Ich verstehe nicht, warum das so ist, vor allem nicht, warum der
> falsche Name mit dem Hostnamen aufgelöst wird. Welche
> Optionen/Möglichkeiten habe ich noch, um der Sache auf
> den Grund zu gehen,...?


Ich kann mich nur wiederholen: Am TAP-Win32 Adapter darf keine IP aus dem
Kreis 192.168.1.x vergeben werden und schon garnicht Standardgateway und
DNS.
Du könntest am TAB-Win32-Adapter NetBios über TCP/IP deaktivieren.
Warum gibst Du dem Adapter nicht einfach eine IP aus einem anderen Subnetz,
also z.B die 192.168.2.9?

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Reply With Quote
  #7 (permalink)  
Old 06-16-2008
Kerem Gümrükcü
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Hallo Ralf,

> Ich kann mich nur wiederholen: Am TAP-Win32 Adapter darf keine IP aus dem
> Kreis 192.168.1.x vergeben werden und schon garnicht Standardgateway und
> DNS.
> Du könntest am TAB-Win32-Adapter NetBios über TCP/IP deaktivieren.
> Warum gibst Du dem Adapter nicht einfach eine IP aus einem anderen
> Subnetz, also z.B die 192.168.2.9?



letztendlich habe ich das auch so gemacht, wie Du
vorgeschlagen hattest,...

Was ist nun das eigentliche Problem, das da entsteht, kannst
Du mir das bitte vielleicht erklären, denn an sich sollte das
keine Probleme machen, zumindest hat es das nie vorher,...

Grüße

Kerem

--
-----------------------
Beste Grüsse / Best regards / Votre bien devoue
Kerem Gümrükcü
Microsoft Live Space: http://kerem-g.spaces.live.com/
Latest Open-Source Projects: http://entwicklung.junetz.de
-----------------------
"This reply is provided as is, without warranty express or implied."


Reply With Quote
  #8 (permalink)  
Old 06-16-2008
Ralf Breuer
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...
Kerem Gümrükcü <kareem114@hotmail.com> schrieb:

> Was ist nun das eigentliche Problem, das da entsteht, kannst
> Du mir das bitte vielleicht erklären, denn an sich sollte das
> keine Probleme machen, zumindest hat es das nie vorher,...


Wenn zwei Netzwerkadapter im gleichen Subnetz liegen, ist es "Zufall",
welcher Adapter benutzt wird. Manchmal funktioniert es, manchmal nicht.
Man sollte solche Situationen vermeiden, um Eindeutigkeit herzustellen.

BTW: Es fällt mir gerade erst auf: Du hast den Thread in 4 Gruppen gestartet
ohne zu fuppen und ich hab's auch verpennt. Aber jetzt...

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Reply With Quote
  #9 (permalink)  
Old 06-22-2008
Carsten Beckermann
 

Posts: n/a
Re: Namensauflösung in Netzwerk gibt falshe IP für Host zurück,...

"Kerem Gümrükcü" <kareem114@hotmail.com> schrieb im Newsbeitrag
news:%23ljlV00zIHA.4492@TK2MSFTNGP02.phx.gbl...
> Hallo Ralf,
>
> nun, es erweckte den Anschein, als wenn es funktioniert hat,
> aber obwohl die aktive Karte bei den Bindungen und der
> Anbieterreinfolge ganz oben ist und das gleiche Gültigkeit
> für die Protokollbindungen (IP4 und IP6) hat, bekomme
> ich bei einer Auflösung "wieder" diese 9 statt die 3. Das
> ist irgendwie nix. Hier eine Ausgabe von "ipconfig / all";
>
>
>
> Windows-IP-Konfiguration
>

[...]


Hallo.

Unter XP Pro kenne ich das Problem. Ich deaktiviere einfach die VM Adapter
in Systemsteuerung/Netzwerkadapter.
Um mich daran zu erinnern, habe ich in meine Startup-Script im Autostart
Ordner zusätzliche Zeilen geschrieben, welche mich daran erinnern.
Hier mal die entsprechenden Zeilen. Ich hoffe, sie funktionieren, wenn sie
so aus dem kompletten Kontext der Batch gerissen wurden...

=====SCHNIPP=====
set VMnetz=0
ipconfig|findstr "VMnet" >nul 2>&1 && set VMnetz=1
if "%VMnetz%"=="1" (
echo WScript.Echo ^("VMWare Adapter aktiv!"^)^; >%tmp%\VMaktiv.js
start %tmp%\VMaktiv.js
)
=====SCHNAPP=====


Grüße
Carsten


Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Namensauflösung kaputt SeaStorm microsoft.public.de.windows.vista.netzwerk 9 12-06-2007 09:24
Article ID: 929853 Sie können auf Netzwerkressourcen nicht zugreifen und wenn Sie mit dem Firma-Netzwerk eine VPN-Verbindung von einem Windows Vista-based Computer herstellen ist Domäne-Namensauflösung nicht erfolgreich KBArticles German 0 10-22-2007 21:20
Article ID: 930279 Wenn ein Programm, das auf Simple MAPI (SMAPI) basiert, die Funktion in Windows Vista aufruft, gibt die MAPIFindNext-Funktion den MAPI_E_FAILURE(2)-Fehler zurück KBArticles German 0 10-22-2007 21:20
Article ID: 940069 Eine Indexdienstabfrage, die das LIKE-Prädikat verwendet, gibt ein falsches Ergebnis in Windows Vista zurück KBArticles German 0 10-22-2007 21:20
VPN und Namensauflösung Jürgen Karl microsoft.public.de.windows.vista.netzwerk 4 06-06-2007 13:30




All times are GMT +1. The time now is 06:33.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120