Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Windows Installer startet dauernd

microsoft.public.de.windows.vista.installation






Speedup My PC
Reply
  #1 (permalink)  
Old 10-29-2007
Alfred Malleier
 

Posts: n/a
Windows Installer startet dauernd
Hallo,

ich habe eine VB6-Anwendung installiert und jetzt, sobald ich das Icon der
Anwendung anklicke startet der Installer wie im Infinit-Loop und will
andauernd etwas konfigurieren. Nach vielen Bestätigungen und Warten geht das
Programm allmählich auf, doch sobald ich im Programm navigiere kommt bei
jedem Klick der Installer wieder.

FRAGE: wie kann ich das abdrehen?

Grüße Alfred M.

Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-29-2007
G. Born
 

Posts: n/a
Re: Windows Installer startet dauernd
> ich habe eine VB6-Anwendung installiert und jetzt, sobald ich das Icon der
> Anwendung anklicke startet der Installer wie im Infinit-Loop und will
> andauernd etwas konfigurieren. Nach vielen Bestätigungen und Warten geht
> das Programm allmählich auf, doch sobald ich im Programm navigiere kommt
> bei jedem Klick der Installer wieder.
>
> FRAGE: wie kann ich das abdrehen?
>

Ist vermutlich ein Rechteproblem, dass die Anwendung Administratorrechte
benötigt.

Versuche mal das Ganze zu deinstallieren.

Wiederhole die Installation, indem Du das Setup ggf. über "Als Administrator
ausführen" aufrufst. Kannst ggf. auch versuchen, die Kompatibilitätsoptionen
für das Setup auf WIndows XP zu setzen und "Als Administrator ausführen" in
den Optionen einzustellen.

Wenn ein Installationspfad abgefragt wird, verwende einen eigenen Ordner
(z.B: C:\Name). Könnte sein, dass es dann klappt.

Gibt hier noch ähnliche Infos http://www.vistablog.at/stories/8339/

Vielleicht hilft's weiter.

Gruß

G. Born

Reply With Quote
  #3 (permalink)  
Old 10-29-2007
Thomas D.
 

Posts: n/a
Re: Windows Installer startet dauernd
Hallo Alfred,

mich interessiert, was in der Ereignisanzeige als Grund für den Aufruf des
MSI-Installers genannt wird. Schau doch hier einmal nach...


--
Grüße,
Thomas
Reply With Quote
  #4 (permalink)  
Old 10-29-2007
Renato
 

Posts: n/a
Re: Windows Installer startet dauernd
Thomas D. schrieb:
> Hallo Alfred,
>
> mich interessiert, was in der Ereignisanzeige als Grund für den Aufruf des
> MSI-Installers genannt wird. Schau doch hier einmal nach...
>
>

Hallo Thomas

Danke für den Tip mit der Ereignisanzeige, bei mir war es die fehlende
ariblk.ttf die ein dauerndes starten des Installers (mit der Meldung
fehlende Schriftart, aber ohne weitere Angabe) verursacht hatte.

Gruss Renato
Reply With Quote
  #5 (permalink)  
Old 10-29-2007
Daniel Melanchthon [MSFT]
 

Posts: n/a
Re: Windows Installer startet dauernd
Renato wrote:
> Danke für den Tip mit der Ereignisanzeige, bei mir war es die fehlende
> ariblk.ttf die ein dauerndes starten des Installers (mit der Meldung
> fehlende Schriftart, aber ohne weitere Angabe) verursacht hatte.


starte doch die Anwendung mal mit rechtem Mausklick als Administrator.
Vielleicht will sie ja die Schrift installieren, was sie im normalen
Benutzerkontext nicht darf.

Viele Grüße!
--
..aniel Melanchthon:.
http://blogs.technet.com/dmelanchthon
This posting is provided "AS IS" with no warranties, and confers no rights.

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität!

Reply With Quote
  #6 (permalink)  
Old 10-29-2007
Renato
 

Posts: n/a
Re: Windows Installer startet dauernd
Daniel Melanchthon [MSFT] schrieb:
> Renato wrote:
>> Danke für den Tip mit der Ereignisanzeige, bei mir war es die fehlende
>> ariblk.ttf die ein dauerndes starten des Installers (mit der Meldung
>> fehlende Schriftart, aber ohne weitere Angabe) verursacht hatte.

>
> starte doch die Anwendung mal mit rechtem Mausklick als Administrator.
> Vielleicht will sie ja die Schrift installieren, was sie im normalen
> Benutzerkontext nicht darf.
>
> Viele Grüße!


Danke für den Hinweis
Habe das File von einem anderen PC ins Verzeichnis Windows/Fonts kopiert
und nun ist Ruhe.
Gruss Renato
Reply With Quote
  #7 (permalink)  
Old 10-30-2007
Alfred Malleier
 

Posts: n/a
Re: Windows Installer startet dauernd
Vielen Dank an euch für die beiden entscheidenden Hinweise. Der Tag hatte so
schön begonnen, als ich

1) im Event Viewer sah, dass der Installer nach C:\WinCo suchte obwohl das
Installationsverzeichnis C:\Programfiles\WinCo war

2) ich alles deinstallierte und dann wie von Born vorgeschlagen direkt in
C:\WinCo installierte

Das Programm ging wunderbar auf, mit oder ohne UAC aktiviert und der
Installer startet nicht ein einziges mal. Übrigends denke ich war es von
Anfang an kein Rechteproblem.

Doch als ich dann den PC aufräumen wollte und die Überreste des vielen
Probierens aus dem alten C:\Programme\WinCo entfernte ging alles von vorne
los. Nun sucht der Installer im Infinitiv-Loop nach C:\Programme\WinCo. Also
habe ich deinstalliert und die Installation mit neuem Upgrade- und
Productcode erstellt und neu installiert. Nichts, jetzt ist auch noch der
Eventviewer abgestürtzt und ich bin fast beim Durchdrehen.

Seit der Installation von Novell Netware Ende der 80er Jahre, als ich
stundenlang mit 13 Disketten DJ spielte um am Ende zu sehen, dass die
Installation abgebrochen werden musste, habe ich nichts mehr so
frustrierendes erlebt, wie die Installation meiner VB6 Anwendung unter
Windows Vista. Ich übertreibe nicht, habe Tage verloren und wenn man im
Internet sucht sieht alles aus, als ob es das Problem nicht gäbe. Tatsache
ist aber, dass in meinem Kundenkreis von 100 Kunden erst 2 Stationen mit
Windows Vista bekannt sind (also weniger als 1% der PCs). Sämtliche
HW-Verkäufer bieten ausschließlich XP Prof. an, mit Ausnahme von einigen
Laptops, welche ohne Vista nicht mehr erhältlich sind.

Die Meldung im Event Viewer lautet etwa:

Event1: Fehler beim Auffinden des Produktes (GUID), Charakteristik
"Complete", Komponetente (GUID). Die Resource "C:\WinCo" exitiert nicht

(obwohl ich dort nie etwas installiert habe)

Event2: Fehler beim Auffinden der Charakteristik "Complete" von (GUID). Der
Fehler hat sich auf Anfrage der Komponente (GUID) ereignet.

Nun, da es C:\Programme\WinCo nicht mehr gibt, steht dort eben dieses
Verzeichnis.

Ich wäre sehr dankbar, wenn ich dieses Problem lösen könnte.

WIE KANN MAN UNTERBINDEN, DASS DER INSTALLER DIE INSTALLIERTEN KOMPONENTEN
ÜBERWACHT. DENN ICH MUSS DORT NACH DER INSTALLATION EINE DATEI AUSTAUSCHEN,
WELCHE ICH VOM ALTEN PC ÜBERNEHMEN MUSS.

Ansonsten finde ich Vista toll und arbeite gerne damit.

Viele Grüße

Alfred Malleier



Reply With Quote
  #8 (permalink)  
Old 10-30-2007
Alfred Malleier
 

Posts: n/a
Re: Windows Installer startet dauernd
Born schrieb:

>> Ist vermutlich ein Rechteproblem, dass die Anwendung Administratorrechte
>> benötigt.


>> Versuche mal das Ganze zu deinstallieren.


>> Wiederhole die Installation, indem Du das Setup ggf. über "Als
>> Administrator ausführen" aufrufst. Kannst ggf. auch versuchen, die
>> Kompatibilitätsoptionen für das Setup auf WIndows XP zu setzen und "Als
>> Administrator ausführen" in den Optionen einzustellen.


darauf kommt man ja recht bald. Das war nicht das Problem


>> Wenn ein Installationspfad abgefragt wird, verwende einen eigenen Ordner
>> (z.B: C:\Name). Könnte sein, dass es dann klappt.


das war der entscheidende Hinweis. Nicht nach C:\Programme installieren
sondern irgendwo sonst.

>> Gibt hier noch ähnliche Infos http://www.vistablog.at/stories/8339/


da war ich bei meinen Recherchen bereits. Stimmt leider nicht, dass wenn
eine App unter XP SP2 läuft sie dann auch unter Vista läuft.

Danke Alfred M.



Reply With Quote
  #9 (permalink)  
Old 10-30-2007
Alfred Malleier
 

Posts: n/a
Re: Windows Installer startet dauernd
"Thomas D. schrieb:

> mich interessiert, was in der Ereignisanzeige als Grund für den Aufruf des
> MSI-Installers genannt wird. Schau doch hier einmal nach...


Ich habe im Eventviewer nach Virtual Directory gesucht, doch nach dem
Installer zu suchen ist mir nicht in den Sinn gekommen. Ich weiß nicht liegt
es am Installationsprogramm (WISE) oder beim Vista, dass der Installer in
einem falschen Verzeichnis nach der Komponente sucht und dann im
Infinitiv-Loop bleibt.

Wems insteressiert hier die Originalmeldung des Installers (ital. PC des
Kunden):

Übersetzung:

1) im Event Viewer sah, dass der Installer nach C:\WinCo suchte obwohl das
Installationsverzeichnis C:\Programfiles\WinCo war

2) ich alles deinstallierte und dann wie von Born vorgeschlagen direkt in
C:\WinCo installierte

Grüße Alfred M.


Errore durante il rilevamento del prodotto
"{842BDC5A-4B35-4252-910C-3B74F8EC4178}", caratteristica "Complete",
componente "{8028A198-E637-472B-8A2B-336086ED417A}". La risorsa "C:\WinCo\"
non esiste.



- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

- <System>

<Provider Name="MsiInstaller" />

<EventID Qualifiers="0">1004</EventID>

<Level>3</Level>

<Task>0</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2007-10-30T05:49:49.000Z" />

<EventRecordID>4327</EventRecordID>

<Channel>Application</Channel>

<Computer>PC-tipmaz</Computer>

<Security UserID="S-1-5-21-238309369-3126994160-2131755150-1000" />

</System>

- <EventData>

<Data>{842BDC5A-4B35-4252-910C-3B74F8EC4178}</Data>

<Data>Complete</Data>

<Data>{8028A198-E637-472B-8A2B-336086ED417A}</Data>

<Data>C:\WinCo\</Data>

<Data>(NULL)</Data>

<Data />

<Data />

</EventData>

</Event>







Errore durante il rilevamento della caratteristica "Complete" di
"{842BDC5A-4B35-4252-910C-3B74F8EC4178}". L'errore si è verificato durante
una richiesta per il componente "{5C515D40-2831-41FA-9333-AD07C8820C4F}".



- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

- <System>

<Provider Name="MsiInstaller" />

<EventID Qualifiers="0">1001</EventID>

<Level>3</Level>

<Task>0</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2007-10-30T05:49:49.000Z" />

<EventRecordID>4328</EventRecordID>

<Channel>Application</Channel>

<Computer>PC-tipmaz</Computer>

<Security UserID="S-1-5-21-238309369-3126994160-2131755150-1000" />

</System>

- <EventData>

<Data>{842BDC5A-4B35-4252-910C-3B74F8EC4178}</Data>

<Data>Complete</Data>

<Data>{5C515D40-2831-41FA-9333-AD07C8820C4F}</Data>

<Data>(NULL)</Data>

<Data>(NULL)</Data>

<Data />

<Data />

</EventData>

</Event>


>
>
> --
> Grüße,
> Thomas



Reply With Quote
  #10 (permalink)  
Old 10-30-2007
G. Born
 

Posts: n/a
Re: Windows Installer startet dauernd
>>> Ist vermutlich ein Rechteproblem, dass die Anwendung Administratorrechte
>>> benötigt.

>

.....
>>> Wenn ein Installationspfad abgefragt wird, verwende einen eigenen Ordner
>>> (z.B: C:\Name). Könnte sein, dass es dann klappt.

>
> das war der entscheidende Hinweis. Nicht nach C:\Programme installieren
> sondern irgendwo sonst.


Also hat die Virtualisierung des Ordners "Programme" wohl zugeschlagen.
ERklärt auch die von Dir gemeldeten Probleme in den nebenläufigen Threads -
hoffe ich wenigstens.

Gruß

G. Born

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Article ID: 934538 Vous ne pouvez pas activer une fonction facultative, ne pouvez pas installer pour un kit de langue sur un ordinateur Windows Vista-based, ne pouvez pas installer un correctif ou ne pouvez pas installer une mise jour Windows KBArticles French 0 10-23-2007 20:00
Article ID: 939397 L'icne UAC bouclier n'apparat pas en mode maintenance sur le contrle UI PushButton natif Windows Installer lorsque vous utilisez Windows Installer 4.0 sur un ordinateur Windows Vista-based KBArticles French 0 10-23-2007 20:00
Article ID: 939397 Wenn Sie Windows Installer 4.0 auf einem Windows Vista-based Computer verwenden, wird das UAC-Schildsymbol UI PushButton auf dem systemeigenen Windows Installer-Steuerelement in Wartungsmodus nicht angezeigt KBArticles German 0 10-22-2007 21:20
Article ID: 939397 The UAC shield icon does not appear on the Windows Installer native UI PushButton control during maintenance mode when you use Windows Installer 4.0 on a Windows Vista-based computer KBArticles English 0 10-22-2007 20:00
WINDOWS IE startet nicht Ludwig microsoft.public.de.windows.vista.sonstiges 11 09-09-2007 21:04




All times are GMT +1. The time now is 06:45.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120