Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

Java funktioniert nicht unter Vista Home Premium 32bit

microsoft.public.de.windows.vista.bedienung






Speedup My PC
Reply
  #1 (permalink)  
Old 04-07-2008
Gerd Jakobs
 

Posts: n/a
Java funktioniert nicht unter Vista Home Premium 32bit
Tach auch.

Nachdem ich bereits gestern gut 4 Stunden damit verbracht habe, ohne zu
einem Ergebnis zu kommen, frage ich mal in dieser NG nach und hoffe,
hier auch OT zu sein. Falls nicht, bitte entsprechend verschieben.

Ich verzweifle echt an Vista Home Premium 32bit und Java :-(

Zuerst mal mein Leidensweg:

Ich habe mit dem aktuellen SeaMonkey 1.1.9 aber auch mit IE und Safari
einige Seiten angesurft, die halt eben immer ein fehlendes Java-Plugin
bemängelt hatten. Java war aber bei mir definitiv installiert, unter
Systemsteuerung konnte ich es finden.

Also Java geöffnet und halt dort erst mal unter Anwendungsinfo
nachgeschaut. Da kann man dann Version 6 Aktualisierung 5 (Build
1.6.0_05-b13) lesen.
Nun unter 'Erweitert\Standard-Java für Browser' geschaut. Weder bei M$
IE noch bei Mozilla-Familie ist ein Häkchen gesetzt. Ok dachte ich mir,
Haken gesetzt und Anwenden geklickt.
Denkste: Ein wirklich riesengroßes Fehlerfenster erscheint mit dem
Inhalt: Browsereinstellungen können nicht geändert werden. Prüfen Sie,
ob Sie über die erforderlichen Berechtigungen zum Ändern der
Systemeinstellungen verfügen.
Hmm, stimmt, ich bin unter einem eingeschränkten Konto angemeldet, also
abgemeldet und als Admin angemeldet, aber von wegen; auch hier genau das
gleiche Spiel :-(

Java komplett deinstalliert und dann die komplette JDK installiert
(jdk-6u5-windows-i586-p.exe) da ich mich eh mal intensiver damit
beschäftigen wollte.
Nach der Neuinstallation funktioniert auch alles tatsächlich. Die
fehlenden Haken sind zumindest für M$ und die Anzeige in der Taskleiste
gesetzt. Hab dann noch den Haken für die Mozilla-Familie gesetzt und das
funktionierte auch diesmal ohne Fehlermeldung.

Dann noch getestet mit
http://www.chemgapedia.de/vsengine/i...ents/java.html

Dort stand dann in grüner Schrift: Installierte Java-Version 1.6.0_05
und in rot, dass Java3D nicht installiert wäre.

Ok und fein, läuft also. Den Browser von SeaMonkey geschlossen und
Safari geöffnet mit der SELBEN Seite. Safari meldet sofort, dass Java
NICHT installiert wäre.

Java noch mal aufgerufen, die Haken sind wieder weg und wenn ich sie
wieder setzen will erscheint die bekannte Fehlermeldung...


Google spuckte mir zu dem Thema diese Links aus, die mir aber nicht
weiterhalfen:

http://www.winfuture-forum.de/index....T&f=1&t=103592

Hier ging es leider um die 64bit-Version.

Jemand meint dann im Thread, man solle auf die alte original M$-Java-VM
setzen, die zwar von M$ nicht mehr gepflegt wird, dafür aber auch unter
Vista problemlos funktionieren soll.

Dieser Beitrag http://www.wintotal.de/softw/?rb=6&id=1034 läßt mich von
dem Vorschlag aber eher Abstand halten, da es ja offensichtlich Fehler
in der M$ VM gibt, die zumindest unter XP eine Systemgefährdung
ermöglichen und dazu gibt es dann die KB816093.

Weis jemand, ob dieser Fehler auch auf Vista zutrifft oder kann man die
alte M$ VM tatsächlich problemlos unter Vista nutzen?

Wie kann ich die SUN-VM unter Vista korrekt zum laufen bringen?

Ich danke schon mal für jeden hilfreien Tipp.

MfG, Gerd
--
Die chinesichen Fernsehmacher wollen vom Deutschen Fernsehen lernen.
Geplant sind Schowprozesse mit dem Titel: "7 Tage - 7 Köpfe".
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-07-2008
Helmut Rohrbeck
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Gerd Jakobs schrieb:

> Ich habe mit dem aktuellen SeaMonkey 1.1.9 aber auch mit IE und Safari
> einige Seiten angesurft, die halt eben immer ein fehlendes Java-Plugin
> bemängelt hatten. Java war aber bei mir definitiv installiert, unter
> Systemsteuerung konnte ich es finden.
>
> Also Java geöffnet und halt dort erst mal unter Anwendungsinfo
> nachgeschaut. Da kann man dann Version 6 Aktualisierung 5 (Build
> 1.6.0_05-b13) lesen.
> Nun unter 'Erweitert\Standard-Java für Browser' geschaut. Weder bei M$
> IE noch bei Mozilla-Familie ist ein Häkchen gesetzt. Ok dachte ich
> mir, Haken gesetzt und Anwenden geklickt.
> Denkste: Ein wirklich riesengroßes Fehlerfenster erscheint mit dem
> Inhalt: Browsereinstellungen können nicht geändert werden. Prüfen Sie,
> ob Sie über die erforderlichen Berechtigungen zum Ändern der
> Systemeinstellungen verfügen.
> Hmm, stimmt, ich bin unter einem eingeschränkten Konto angemeldet,
> also abgemeldet und als Admin angemeldet, aber von wegen; auch hier
> genau das gleiche Spiel :-(


Normalerweise erkennt VISTA, dass ein Installationsvorgang gestartet
wurde und fordert erhöhte Rechte dafür an. Du hast "UAC" deaktiviert?
Dann kommt diese Anforderung nicht, und das Installationsprogramm
kann nicht in die Registry schreiben, weil die Rechte dafür fehlen.

Außerdem gibt es Virenschutzprogramme, die den Schreibzugriff auf die
Registry generell unterbinden. Dagegen hilft nur eine Deinstallation
des Schutzprogramms, "Deaktivieren" genügt meistens nicht, weil
die Blockade bereits beim Booten des Systems geladen wird.

--
Helmut Rohrbeck www.helmrohr.de
Mail nur über das Kontaktformular
auf meiner Webseite!
Reply With Quote
  #3 (permalink)  
Old 04-07-2008
Gerd Jakobs
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Helmut Rohrbeck kitzelte am 07.04.2008 15:27 dies aus einer Tastatur:
> Gerd Jakobs schrieb:
>
>> Ich habe mit dem aktuellen SeaMonkey 1.1.9 aber auch mit IE und Safari
>> einige Seiten angesurft, die halt eben immer ein fehlendes Java-Plugin
>> bemängelt hatten. Java war aber bei mir definitiv installiert, unter
>> Systemsteuerung konnte ich es finden.
>>
>> Also Java geöffnet und halt dort erst mal unter Anwendungsinfo
>> nachgeschaut. Da kann man dann Version 6 Aktualisierung 5 (Build
>> 1.6.0_05-b13) lesen.
>> Nun unter 'Erweitert\Standard-Java für Browser' geschaut. Weder bei M$
>> IE noch bei Mozilla-Familie ist ein Häkchen gesetzt. Ok dachte ich
>> mir, Haken gesetzt und Anwenden geklickt.
>> Denkste: Ein wirklich riesengroßes Fehlerfenster erscheint mit dem
>> Inhalt: Browsereinstellungen können nicht geändert werden. Prüfen Sie,
>> ob Sie über die erforderlichen Berechtigungen zum Ändern der
>> Systemeinstellungen verfügen.
>> Hmm, stimmt, ich bin unter einem eingeschränkten Konto angemeldet,
>> also abgemeldet und als Admin angemeldet, aber von wegen; auch hier
>> genau das gleiche Spiel :-(

>
> Normalerweise erkennt VISTA, dass ein Installationsvorgang gestartet
> wurde und fordert erhöhte Rechte dafür an. Du hast "UAC" deaktiviert?
> Dann kommt diese Anforderung nicht, und das Installationsprogramm
> kann nicht in die Registry schreiben, weil die Rechte dafür fehlen.
>
> Außerdem gibt es Virenschutzprogramme, die den Schreibzugriff auf die
> Registry generell unterbinden. Dagegen hilft nur eine Deinstallation
> des Schutzprogramms, "Deaktivieren" genügt meistens nicht, weil
> die Blockade bereits beim Booten des Systems geladen wird.
>

Also ich hab mich jetzt wieder gut 3 Stunden mit dem Sch**** rumgequält,
das Ergebnis ist äußerst merkwürdig.

Unter meinem zweiten Administratorkonto funktioniert es einwandfrei!
Nur das Standard-Adminkonto und eben mein reguläres eingeschränktes
Benutzerkonto für die tägliche Arbeit wollen Java einfach aus mir
absolut nicht nachvollziehbaren Gründen nicht erkennen / akzeptieren.

UAC ist nicht deaktiviert, ich war zur Installation als Admin angemeldet
und als Virenscanner läuft hier AVAST mit den von Dir empfohlenen
Einstellungen.

So wie das ausschaut, werde ich Vista wohl tatsächlich neu aufsetzen
müssen, wenn hier niemand eine rettende Idee dazu hat...

MfG, Gerd


--
Fußball ist Ding, Dang, Dong. Es gibt nicht nur Ding.
[Giovanni Trappatoni]
Reply With Quote
  #4 (permalink)  
Old 04-08-2008
Gerd Jakobs
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Bevor ich Vista neu installiere verschiebe ich den Thread mal nach dclj
aber ohne FUP2, da wohl nicht viele die NG beziehen dürften und man dann
auch hier die Antworten mitlesen kann, falls sonst noch jemand mal das
selbe Problem haben sollte.


> Tach auch.
>
> Nachdem ich bereits gestern gut 4 Stunden damit verbracht habe, ohne zu
> einem Ergebnis zu kommen, frage ich mal in dieser NG nach und hoffe,
> hier auch OT zu sein. Falls nicht, bitte entsprechend verschieben.
>
> Ich verzweifle echt an Vista Home Premium 32bit und Java :-(
>
> Zuerst mal mein Leidensweg:
>
> Ich habe mit dem aktuellen SeaMonkey 1.1.9 aber auch mit IE und Safari
> einige Seiten angesurft, die halt eben immer ein fehlendes Java-Plugin
> bemängelt hatten. Java war aber bei mir definitiv installiert, unter
> Systemsteuerung konnte ich es finden.
>
> Also Java geöffnet und halt dort erst mal unter Anwendungsinfo
> nachgeschaut. Da kann man dann Version 6 Aktualisierung 5 (Build
> 1.6.0_05-b13) lesen.
> Nun unter 'Erweitert\Standard-Java für Browser' geschaut. Weder bei M$
> IE noch bei Mozilla-Familie ist ein Häkchen gesetzt. Ok dachte ich mir,
> Haken gesetzt und Anwenden geklickt.
> Denkste: Ein wirklich riesengroßes Fehlerfenster erscheint mit dem
> Inhalt: Browsereinstellungen können nicht geändert werden. Prüfen Sie,
> ob Sie über die erforderlichen Berechtigungen zum Ändern der
> Systemeinstellungen verfügen.
> Hmm, stimmt, ich bin unter einem eingeschränkten Konto angemeldet, also
> abgemeldet und als Admin angemeldet, aber von wegen; auch hier genau das
> gleiche Spiel :-(
>
> Java komplett deinstalliert und dann die komplette JDK installiert
> (jdk-6u5-windows-i586-p.exe) da ich mich eh mal intensiver damit
> beschäftigen wollte.
> Nach der Neuinstallation funktioniert auch alles tatsächlich. Die
> fehlenden Haken sind zumindest für M$ und die Anzeige in der Taskleiste
> gesetzt. Hab dann noch den Haken für die Mozilla-Familie gesetzt und das
> funktionierte auch diesmal ohne Fehlermeldung.
>
> Dann noch getestet mit
> http://www.chemgapedia.de/vsengine/i...ents/java.html
>
> Dort stand dann in grüner Schrift: Installierte Java-Version 1.6.0_05
> und in rot, dass Java3D nicht installiert wäre.
>
> Ok und fein, läuft also. Den Browser von SeaMonkey geschlossen und
> Safari geöffnet mit der SELBEN Seite. Safari meldet sofort, dass Java
> NICHT installiert wäre.
>
> Java noch mal aufgerufen, die Haken sind wieder weg und wenn ich sie
> wieder setzen will erscheint die bekannte Fehlermeldung...
>
>
> Google spuckte mir zu dem Thema diese Links aus, die mir aber nicht
> weiter halfen:
>
> http://www.winfuture-forum.de/index....T&f=1&t=103592
>
> Hier ging es leider um die 64bit-Version.
>
> Jemand meint dann im Thread, man solle auf die alte original M$-Java-VM
> setzen, die zwar von M$ nicht mehr gepflegt wird, dafür aber auch unter
> Vista problemlos funktionieren soll.
>
> Dieser Beitrag http://www.wintotal.de/softw/?rb=6&id=1034 läßt mich von
> dem Vorschlag aber eher Abstand halten, da es ja offensichtlich Fehler
> in der M$ VM gibt, die zumindest unter XP eine Systemgefährdung
> ermöglichen und dazu gibt es dann die KB816093.
>
> Weis jemand, ob dieser Fehler auch auf Vista zutrifft oder kann man die
> alte M$ VM tatsächlich problemlos unter Vista nutzen?
>
> Wie kann ich die SUN-VM unter Vista korrekt zum laufen bringen?
>
> Ich danke schon mal für jeden hilfreichen Tipp.
>
> MfG, Gerd


Dann habe ich gestern noch folgendes festgestellt und auch schon in der
Ursprungs-NG mitgeteilt:

> Unter meinem zweiten Administratorkonto funktioniert es einwandfrei!
> Nur das Standard-Adminkonto und eben mein reguläres eingeschränktes
> Benutzerkonto für die tägliche Arbeit wollen Java einfach aus mir
> absolut nicht nachvollziehbaren Gründen nicht erkennen / akzeptieren.
>
> UAC ist nicht deaktiviert, ich war zur Installation als Admin angemeldet
> und als Virenscanner läuft hier AVAST mit den von Dir empfohlenen
> Einstellungen.


Hier die entsprechenden MIDs zu den bis jetzt eingegangenen Antworten:

<ftdehr.94.1@helmrohr.de>

<ftdevp$7hm$01$1@news.t-online.com>

Wäre wirklich super, wenn mir hier jemand weiterhelfen könnte...

MfG, Gerd
Reply With Quote
  #5 (permalink)  
Old 04-10-2008
Gerd Jakobs
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Schade, hat wirklich niemand eine Idee, außer Vista neu aufzusetzen?

MfG, Gerd

--
Zu 50 Prozent stehen wir im Viertelfinale, aber die halbe Miete ist das
noch lange nicht!
[Rudi Völler]
Reply With Quote
  #6 (permalink)  
Old 04-10-2008
Michael Osipov
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Gerd Jakobs wrote:
> Schade, hat wirklich niemand eine Idee, außer Vista neu aufzusetzen?


Das Problem ist leider viel zu allgemein um das per Remote zu machen.
Ist das ein vorinstalliertes Windows von einem Hersteller?

DU hättest folgende Möglichkeit: Installiere dein Vista von der
mitgelieferten DVD in VirtualBox, dort dann das JDK rein und teste es
dort. Dann weißt du ganz gena, hoffentlich, was Sache ist.

Bei Windows ist eine Neuinstallition oft besser als flicken. Siehe
verseuchtes Windows bei Sony VAIO.

M

Reply With Quote
  #7 (permalink)  
Old 04-10-2008
Michael Osipov
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Michael Osipov wrote:
> Gerd Jakobs wrote:
>> Schade, hat wirklich niemand eine Idee, außer Vista neu aufzusetzen?

>
> Das Problem ist leider viel zu allgemein um das per Remote zu machen.

^^^^^^^^^

sorry, sollte speziell heißen
Reply With Quote
  #8 (permalink)  
Old 04-10-2008
Helmut Rohrbeck
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Gerd Jakobs schrieb:

> Schade, hat wirklich niemand eine Idee, außer Vista neu aufzusetzen?

,-- [ Zitat aus Deinem Vorposting: ]
| Unter meinem zweiten Administratorkonto funktioniert es einwandfrei!
| Nur das Standard-Adminkonto und eben mein reguläres eingeschränktes
| Benutzerkonto für die tägliche Arbeit wollen Java einfach aus mir
| absolut nicht nachvollziehbaren Gründen nicht erkennen / akzeptieren.
`--------
Meinst Du mit "Standard-Adminkonto" etwa, dass Du das in VISTA
vorhandene Konto "Administrator", welches normalerweise deaktiviert
ist, *aktiviert* und bei der Installation verwendet hast?

Dann hilft evtl. folgendes:
Deinstalliere unter Systemsteuerung => Programme und Funktionen
"Java(TM) 6 Update 5" und evtl. vorhandene frühere Java-Versionen
vollständig. Deaktiviere das Built-in Administrator-Konto wieder.
Lösche nach Deinstallation von Java den Ordner "Java" im Ordner
"Programme", er wird bei der Deinstallation nicht entfernt.

Installiere dann Java komplett neu mit der Option "Als Administrator
ausführen". Aktiviere im Setup die Optionen für die Installation
von Plug-Ins für Mozilla-Familie und ActiveX-Control für IE 7.
Lade Dir die komplette Setup-Datei hier herunter:
http://javadl.sun.com/webapps/downlo...BundleId=18713

--
Helmut Rohrbeck www.helmrohr.de
Mail nur über das Kontaktformular
auf meiner Webseite!
Reply With Quote
  #9 (permalink)  
Old 04-14-2008
Gerd Jakobs
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Helmut Rohrbeck kitzelte am 10.04.2008 20:33 dies aus einer Tastatur:
> Gerd Jakobs schrieb:
>
>> Schade, hat wirklich niemand eine Idee, außer Vista neu aufzusetzen?

> ,-- [ Zitat aus Deinem Vorposting: ]
> | Unter meinem zweiten Administratorkonto funktioniert es einwandfrei!
> | Nur das Standard-Adminkonto und eben mein reguläres eingeschränktes
> | Benutzerkonto für die tägliche Arbeit wollen Java einfach aus mir
> | absolut nicht nachvollziehbaren Gründen nicht erkennen / akzeptieren.
> `--------
> Meinst Du mit "Standard-Adminkonto" etwa, dass Du das in VISTA
> vorhandene Konto "Administrator", welches normalerweise deaktiviert
> ist, *aktiviert* und bei der Installation verwendet hast?


Nein, ich habe 2 eigene Admin-Konten eingerichtet, damit ich die
Benutzereinstellungen kopieren konnte. Das geht ja AFAIK nur so.

> Installiere dann Java komplett neu mit der Option "Als Administrator
> ausführen". Aktiviere im Setup die Optionen für die Installation
> von Plug-Ins für Mozilla-Familie und ActiveX-Control für IE 7.
> Lade Dir die komplette Setup-Datei hier herunter:
> http://javadl.sun.com/webapps/downlo...BundleId=18713


Hmm, ist das nicht eine ältere Version, die das aktuelle Update noch
nicht enthält?

Meine Datei nennt sich jre-6u5-windows-i586-p.exe, die verlinkte Datei
nennt sich jre-6u2-windows-i586-p-s.exe. Netter Weise stehen keine
Versions-Informationen in den Dateien drin :-(

MfG, Gerd
--
Das Herz ist ein kräftig gebauter Schließmuskel.
Reply With Quote
  #10 (permalink)  
Old 04-14-2008
Helmut Rohrbeck
 

Posts: n/a
Re: Java funktioniert nicht unter Vista Home Premium 32bit
Gerd Jakobs schrieb:

> Helmut Rohrbeck kitzelte am 10.04.2008 20:33 dies aus einer Tastatur:
>> Gerd Jakobs schrieb:
>>
>>> Schade, hat wirklich niemand eine Idee, außer Vista neu aufzusetzen?

>> ,-- [ Zitat aus Deinem Vorposting: ]
>>> Unter meinem zweiten Administratorkonto funktioniert es
>>> einwandfrei! Nur das Standard-Adminkonto und eben mein reguläres
>>> eingeschränktes Benutzerkonto für die tägliche Arbeit wollen Java
>>> einfach aus mir absolut nicht nachvollziehbaren Gründen nicht
>>> erkennen / akzeptieren.

>> `--------
>> Meinst Du mit "Standard-Adminkonto" etwa, dass Du das in VISTA
>> vorhandene Konto "Administrator", welches normalerweise deaktiviert
>> ist, *aktiviert* und bei der Installation verwendet hast?

>
> Nein, ich habe 2 eigene Admin-Konten eingerichtet, damit ich die
> Benutzereinstellungen kopieren konnte. Das geht ja AFAIK nur so.
>
>> Installiere dann Java komplett neu mit der Option "Als Administrator
>> ausführen". Aktiviere im Setup die Optionen für die Installation
>> von Plug-Ins für Mozilla-Familie und ActiveX-Control für IE 7.
>> Lade Dir die komplette Setup-Datei hier herunter:
>> http://javadl.sun.com/webapps/downlo...BundleId=18713

>
> Hmm, ist das nicht eine ältere Version, die das aktuelle Update noch
> nicht enthält?
>
> Meine Datei nennt sich jre-6u5-windows-i586-p.exe, ...


Wenn ich den obigen Link anklicke, wird genau die von Dir
angegebene Datei heruergeladen:
***jre-6u5-windows-i586-p.exe***

--
Helmut Rohrbeck www.helmrohr.de
Mail nur über das Kontaktformular
auf meiner Webseite!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
DMA-Modus für DVD-Laufwerke funktioniert unter Vista 64 nicht Alexander Arnold microsoft.public.de.windows.vista.sonstiges 8 03-25-2008 17:26
Identifizierung auf Website mit IE7 / Vista Home premium funktioniert nicht, will file herunterladen, Firefox geht! Lenz Martin microsoft.public.de.windows.vista.sonstiges 0 03-20-2008 14:14
ISDN-Verbindung funktioniert unter Vista nicht mehr, die mit XP schonfunktioniert M.Erlinger microsoft.public.de.windows.vista.netzwerk 0 01-10-2008 14:59
Creative X-FI funktioniert nicht richtig unter Vista 64 Bit email microsoft.public.de.windows.vista.hardware 2 10-11-2007 13:59
Retail 32bit vista Home Premium upgrade to 64 bit Home Premium - H rrdToledo microsoft.public.windows.vista.general 5 09-25-2007 04:38




All times are GMT +1. The time now is 14:15.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120