Microsoft Windows Vista Community Forums - Vistaheads
Recommended Download



Welcome to the Microsoft Windows Vista Community Forums - Vistaheads, YOUR Largest Resource for Windows Vista related information.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so , join our community today!

If you have any problems with the registration process or your account login, please contact us.

Driver Scanner

CurrentControlSet manuell setzen

microsoft.public.de.windows.vista.administration






Speedup My PC
Reply
  #1 (permalink)  
Old 04-15-2007
Thomas Steinbach
 

Posts: n/a
CurrentControlSet manuell setzen
Hallo,

wie setzte ich das ControlSetX (bei mir 5 momentan)
das unter [HKEY_LOCAL_MACHINE\SYSTEM\Select] als

"LastKnownGood"=dword:00000005

gesetzt ist und bei mir als einziges laueft, als
zukuenfitiges default CurrentControlSet, sodass die
fehlerhaften ControlSetX (es) in Zukunft nicht mehr
genutzt werden?

Reicht da einfach ein umschreiben der Werte von

[HKEY_LOCAL_MACHINE\SYSTEM\Select]
"Current"=dword:00000002
"Default"=dword:00000002

in:


[HKEY_LOCAL_MACHINE\SYSTEM\Select]
"Current"=dword:00000005
"Default"=dword:00000005

??? Oder geht mir dann eventuell nichts mehr? Danke

Thomas

--
PS:
Sorry wenn das jetzt jemandem doppelt vorkommt, aber ich denke
die erste mail war zu umstaendlich formuliert, da bisher keinerlei
Antworten kamen
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-16-2007
A. Winkler
 

Posts: n/a
Re: CurrentControlSet manuell setzen

"Thomas Steinbach" <steinbach@gmx-topmail.de> schrieb im Newsbeitrag
news:evu5gs$k3g$01$1@news.t-online.com...
> Hallo,
>
> wie setzte ich das ControlSetX (bei mir 5 momentan)
> das unter [HKEY_LOCAL_MACHINE\SYSTEM\Select] als
>
> "LastKnownGood"=dword:00000005
>
> gesetzt ist und bei mir als einziges laueft, als
> zukuenfitiges default CurrentControlSet, sodass die
> fehlerhaften ControlSetX (es) in Zukunft nicht mehr
> genutzt werden?
>
> Reicht da einfach ein umschreiben der Werte von
>
> [HKEY_LOCAL_MACHINE\SYSTEM\Select]
> "Current"=dword:00000002
> "Default"=dword:00000002
>
> in:
>
>
> [HKEY_LOCAL_MACHINE\SYSTEM\Select]
> "Current"=dword:00000005
> "Default"=dword:00000005
>
> ??? Oder geht mir dann eventuell nichts mehr? Danke
>
> Thomas
>
> --
> PS:
> Sorry wenn das jetzt jemandem doppelt vorkommt, aber ich denke
> die erste mail war zu umstaendlich formuliert, da bisher keinerlei
> Antworten kamen


Hallo,

was Du da versuchst, hilft Dir nicht, wieder zu einem zuverlässigen System
zu kommen, denn selbst die Reparaturfunktion mittels DVD funktioniert ja
nicht mehr. Das sollte aber gehen. Ich rate Dir zu einer Neuinstallation. Du
solltest vor jedem Experiment mit Treibern, etc. einen
Systemwiederherstellungspunkt setzen. Vista hat einige tolle
Sicherheitsfunktionen, die aber nur helfen, wenn man die Voraussetzungen
dafür schafft. Z. B. genug Platz auf den Festplatten für die
Systemwiederherstellung. Wenn man sie abschaltet, sollte man ein gutes
Imageprogramm haben und das Abschalten erst nach dem Anfertigen einer
Image-Datei der Bootpartition versuchen.

Eine Neuinstallation dauert meist nicht so lange wie das "wurschteln" und
die Fehlersuche. Du wirst den Rechner ja sich mal wieder guten Gewissens
ausschalten wollen.

Gruß
Andreas

Reply With Quote
  #3 (permalink)  
Old 04-16-2007
Thomas Steinbach
 

Posts: n/a
Re: CurrentControlSet manuell setzen
Hallo,

>> wie setzte ich das ControlSetX (bei mir 5 momentan)
>> das unter [HKEY_LOCAL_MACHINE\SYSTEM\Select] als
>>
>> "LastKnownGood"=dword:00000005
>>
>> gesetzt ist und bei mir als einziges laueft, als
>> zukuenfitiges default CurrentControlSet, sodass die


> was Du da versuchst, hilft Dir nicht, wieder zu einem zuverlässigen System zu kommen, denn selbst die Reparaturfunktion mittels
> DVD funktioniert ja


Ich habe mal die lkgc exportiert und mit einem Editor
das ControlSet005 gegen ControlSet001 ausgetauscht, dann importiert
und default auf 1 gesetzt. Jetzt habe ich zumindest keinen Bluescreen
mehr, aber beim laden des Loginschirms kommt es nun zum reboot.

Ob jetzt die Windows DVD Recoverfunktion funktionieren wuerde
habe ich noch nicht ausprobiert...
Das umsetzten der default Einstallung auf 5 will ich aber erst als
einer der letzten Moeglichkeiten ausprobieren.

Moeglich waere ja auch wenn man das lkgc in das CurrentControlSet
importiert, vorher halt ControlSetX auf CurrentControlSet setzt.
Aber das weiss ich nicht. Ich hoffe es kann da jemand helfen.

> was Du da versuchst, hilft Dir nicht, wieder zu einem zuverlässigen System zu kommen, denn selbst die Reparaturfunktion mittels
> DVD funktioniert ja nicht mehr. Das sollte aber gehen. Ich rate Dir zu einer Neuinstallation. Du


Jepp, so geht es nicht...

Das Problem war das Vista durch die Neuinstalltation der Treiber
fuer die Festplattenpartitionen und dem Drcheindanderbringen der
gemounteten Pfade keinen Restorepoint mehr gefunden hatte.
Auch _nach_ dem manuellen setzen aller alten Verbindungen
bzw. Mountpoints/pfade. Sah das ungefaehr so aus:

C:\ Missing
C:\UsersRUP Missing
....

> Eine Neuinstallation dauert meist nicht so lange wie das "wurschteln" und die Fehlersuche. Du wirst den Rechner ja sich mal wieder
> guten Gewissens ausschalten wollen.


Ja, da gebe ich dir recht, aber da sind so viele Sachen konfiguriert
(UNIX-Layer, cygwin, versch. Compiler uvam.) das es wieder mind.
einen Monat dauert alles wenigstens notduerftig einzurichten. Diese
Zeit habe ich nur momentan nicht :-( So ca. drei vielleicht sogar vier
Monate _muss_ diese Installation noch laufen...

Komisch ist das alle anderen Betriebssysteme wie SunOS, FreeBSD,
OpenBSD, DOS, linux (debian) einwandfrei funktionieren... Nur
Vista will dann immer wieder neue Treiber installieren wenn lediglich
Boootrecords neu geschrieben wurden, aber in Bezug auf NTFS oder FAT
Partitionen nicht der physikalische Platz auf der Platte noch Groesse
etc. veraendert wurden... :-(

Das Problem scheint mir dabei zu sein, das dann gewisse Mountpoints
verloren gehen und vista mit den restorepoints nichts mehr anfagen
kann...

Jedenfalls sind diese Mountpoints wohl noch nicht richtig ausgereift.
Das ist zumindest mein vorlaeufiger Schluss aus dieser Erfahrung.
Reply With Quote
  #4 (permalink)  
Old 04-16-2007
Thomas Steinbach
 

Posts: n/a
Re: CurrentControlSet manuell setzen
Hallo,

> Eine Neuinstallation dauert meist nicht so lange wie das "wurschteln" und
> die Fehlersuche. Du wirst den Rechner ja sich mal wieder guten Gewissens
> ausschalten wollen.


Mal ein Frage dazu. Kann man Vista auchh quasi als Update
aufspielen. Um sozusagen alte Software und viele Anwendungen
uebernehmen zu koennen?
Reply With Quote
  #5 (permalink)  
Old 04-16-2007
A. Winkler
 

Posts: n/a
Re: CurrentControlSet manuell setzen

"Thomas Steinbach" <steinbach@gmx-topmail.de> schrieb im Newsbeitrag
news:evvfnd$rab$02$1@news.t-online.com...
> Hallo,
>
>>> wie setzte ich das ControlSetX (bei mir 5 momentan)
>>> das unter [HKEY_LOCAL_MACHINE\SYSTEM\Select] als
>>>
>>> "LastKnownGood"=dword:00000005
>>>
>>> gesetzt ist und bei mir als einziges laueft, als
>>> zukuenfitiges default CurrentControlSet, sodass die

>
>> was Du da versuchst, hilft Dir nicht, wieder zu einem zuverlässigen
>> System zu kommen, denn selbst die Reparaturfunktion mittels
>> DVD funktioniert ja

>
> Ich habe mal die lkgc exportiert und mit einem Editor
> das ControlSet005 gegen ControlSet001 ausgetauscht, dann importiert
> und default auf 1 gesetzt. Jetzt habe ich zumindest keinen Bluescreen
> mehr, aber beim laden des Loginschirms kommt es nun zum reboot.
>
> Ob jetzt die Windows DVD Recoverfunktion funktionieren wuerde
> habe ich noch nicht ausprobiert...
> Das umsetzten der default Einstallung auf 5 will ich aber erst als
> einer der letzten Moeglichkeiten ausprobieren.
>
> Moeglich waere ja auch wenn man das lkgc in das CurrentControlSet
> importiert, vorher halt ControlSetX auf CurrentControlSet setzt.
> Aber das weiss ich nicht. Ich hoffe es kann da jemand helfen.
>
>> was Du da versuchst, hilft Dir nicht, wieder zu einem zuverlässigen
>> System zu kommen, denn selbst die Reparaturfunktion mittels
>> DVD funktioniert ja nicht mehr. Das sollte aber gehen. Ich rate Dir zu
>> einer Neuinstallation. Du

>
> Jepp, so geht es nicht...
>
> Das Problem war das Vista durch die Neuinstalltation der Treiber
> fuer die Festplattenpartitionen und dem Drcheindanderbringen der
> gemounteten Pfade keinen Restorepoint mehr gefunden hatte.
> Auch _nach_ dem manuellen setzen aller alten Verbindungen
> bzw. Mountpoints/pfade. Sah das ungefaehr so aus:
>
> C:\ Missing
> C:\UsersRUP Missing
> ...
>
>> Eine Neuinstallation dauert meist nicht so lange wie das "wurschteln" und
>> die Fehlersuche. Du wirst den Rechner ja sich mal wieder
>> guten Gewissens ausschalten wollen.

>
> Ja, da gebe ich dir recht, aber da sind so viele Sachen konfiguriert
> (UNIX-Layer, cygwin, versch. Compiler uvam.) das es wieder mind.
> einen Monat dauert alles wenigstens notduerftig einzurichten. Diese
> Zeit habe ich nur momentan nicht :-( So ca. drei vielleicht sogar vier
> Monate _muss_ diese Installation noch laufen...
>
> Komisch ist das alle anderen Betriebssysteme wie SunOS, FreeBSD,
> OpenBSD, DOS, linux (debian) einwandfrei funktionieren... Nur
> Vista will dann immer wieder neue Treiber installieren wenn lediglich
> Boootrecords neu geschrieben wurden, aber in Bezug auf NTFS oder FAT
> Partitionen nicht der physikalische Platz auf der Platte noch Groesse
> etc. veraendert wurden... :-(
>
> Das Problem scheint mir dabei zu sein, das dann gewisse Mountpoints
> verloren gehen und vista mit den restorepoints nichts mehr anfagen
> kann...
>
> Jedenfalls sind diese Mountpoints wohl noch nicht richtig ausgereift.
> Das ist zumindest mein vorlaeufiger Schluss aus dieser Erfahrung.


Hallo,

ich weiß nicht, warum die Spezialisten sich zurückhalten, ich habe zwar
etwas Ahnung, weiß aber nicht, was Vista bei "last known good" treibt. Ich
kann mir nur vorstellen, daß, wenn Du einen normalen Neustart machst, ein
Treiber immer mit geladen wird, der Vista nicht hochfahren läßt.

Als das bei mir unter XP einmal geschah, konnte ich mit der letzten als
funktionierend bekannten Konfiguration hochfahren und die letzte Aktion
rückgängig machen.

Leider hat sich Microsoft dazu entschlossen, die User von Home und Premium
bei der Komplettsicherung per Image außen vor zu lassen, was ich vollkommen
paradox finde, wo doch soviel Wert auf die Sicherheit gelegt wird.

So ist man auf andere Software angewiesen. Ich habe am Wochenende mit
Acronis gekämpft, irgendwie klappt die Sicherung nicht zuverlässig auf eine
externe USB-Disk. Das scheint an Vista zu liegen, denn mit der gleichen
Festplatte geht es unter XP einwandfrei.

Mal sehen, ob Dir hier jemand einen Tip geben kann, ich weiß es auch nicht.

Gruß
Andreas

Reply With Quote
  #6 (permalink)  
Old 04-16-2007
Thomas Steinbach
 

Posts: n/a
Re: CurrentControlSet manuell setzen
Hallo A,


> ich weiß nicht, warum die Spezialisten sich zurückhalten, ich habe zwar
> etwas Ahnung, weiß aber nicht, was Vista bei "last known good" treibt. Ich
> [...]
> Mal sehen, ob Dir hier jemand einen Tip geben kann, ich weiß es auch
> nicht.


Ja, ich hoffe auch noch das sich mal ein paar Spezialisten
zu dem Thema auessern. Dennoch vielen Dank fuer deine
Muehe bisher...

Thomas
Reply With Quote
  #7 (permalink)  
Old 04-16-2007
Thomas Steinbach
 

Posts: n/a
Re: CurrentControlSet manuell setzen
Mein Rechner bootet wieder eine default-Konfiguration
ohne Absturz und ohne Bluescreen. Aber:

Ich habe jetzt noch das Problem das Vista wohl versucht
Den alten Mountpoint "C:\UsersRUP" fuer eine Partition bzw. eben
diese Partition in das alte "C:\UsersRUP" oder in ein anderes
Verzeichnis irgendwie und/oder irgendwohin zu mounten.
Ich kann mir sonst nicht das sechsmalige Nachfragen nach
Treibern und dann dem quitieren, das dort keine Treiber waeren
nicht erklaeren.

Allerdings geht das mit dem mounten so nicht mehr. Obwohl
das Verzeichnis besteht und leer ist, wird da nichts mehr
gemountet. Die Parttion besteht nach wie vor. In der Registry
finde ich jetzt unter dem Pfad:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVer
sion\Explorer\MountPoints2\CPC\LocalMOF]
"C:\\UsersRUP\\"=""

auch den angegeben Pfad "C:\UsersRUP" Was mache ich nun mit
diesem "verwaisten" Eintrag? Kann ich den einfach loeschen?
Auch in anderen User-Profilen?

Im DeviceManager sind alle alten Eintraege vorhanden,
aber gibt es nun das zusaetliche "Unknown Device".

Wenn ich mir die Eigenschaften dieses Device anschaue
stehen da Informationen in der Form:

Device type: Other Device
Manufacturer: Unknown
Location: on VolumeManager

und unter der Registerkarte Details finde ich den Eintrag

Physical Device Object name
\Device\HarddiskVolume3

So vermute ich zumindest das das also mit dem alten Mountpoint
zusammenhaengt.

Ich habe nun mountvol.exe entdeckt, kann damit aber nicht loeschen.
Es werden mir u.a. auch vier Devices angezeigt die keinen
Laufwerksbuchstaben haben

\\?\Volume{dd3ac97f-8b98-11db-8c53-0011d89c9335}\
*** NO MOUNT POINTS ***
\\?\Volume{dd3ac985-8b98-11db-8c53-0011d89c9335}\
*** NO MOUNT POINTS ***
\\?\Volume{dd3ac99b-8b98-11db-8c53-0011d89c9335}\
*** NO MOUNT POINTS ***
\\?\Volume{dd3ac9a1-8b98-11db-8c53-0011d89c9335}\
*** NO MOUNT POINTS ***

wenn ich:
mountvol.exe \\?\Volume{dd3ac97f-8b98-11db-8c53-0011d89c9335}\ /d
angebe geht das nicht (auch nicht mir /r). Es wird mir
angezeigt das besagtes Verzeichnis nicht leer sei ???

Jetzt kam mir der Gedanke das sich diese Links auf
meine USB-Ports beziehen und habe mit einem USB-Stick das mal
getestet. Allerdings wird dann ein neuer Eintrag erstellt
der dann den entsprechenden Laufwerksbuchsteaben enthaelt
und auch eine andere GUID

die Tools linkd.exe (SRV2003) und delrp.exe (WIN2000) die u.a. auf
http://support.microsoft.com/kb/205524/en-us beschrieben werden,
sind nicht drauf - klar ... aber eben dieses mountvol.exe

Vielleicht kann mir jemand sagen wie ich diese "ungueltigen"
Mountpoints entferne und ob ich das einfach so in der
Registry machen kann oder ob es an ganz was anderem liegt.

Das deinstallieren von diesem "Unknown Device" geht nicht,
bzw. wird dennoch nach dem Neustart nach Treibern gefragt und
nach einem Blick in den Device-Manager ist diese "Unknown Device"
auch wieder vorhanden...
Auch wenn ich die Original Windows Vista DVD angebe.

Mich irritiert in diesem Zusammenhang das
....[MountPoints2\CPC\LocalMOF]... unter
[HKEY_CURRENT_USER]... liegt. Allerdings wohl auch
erklaert, warum es beim Login eines jeden Users
abgefragt, bzw. auch nach einem switch des user und
zurueckkehren abgefragt wird.... zumindest vermute ich
das nun...

Hoffe das weiss jemand was. Gerade von den MS-Profis, wenn
es die hier doch geben sollte ...

Thomas

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
hkey_local_machine\system\currentcontrolset\control\update =?Utf-8?B?bG9zdGludG8=?= microsoft.public.windows.vista.administration accounts passwords 0 02-28-2007 14:10




All times are GMT +1. The time now is 23:58.




Driver Scanner - Free Scan Now

Vistaheads.com is part of the Heads Network. See also XPHeads.com , Win7Heads.com and Win8Heads.com.


Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 RC 2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120